热门标签:
Q:

如何为python2.6安装pip?

我尝试按照这个答案的说明但是easy_install-2.6找不到pip

>sudo easy_install-2.6 pip
Processing pip
error: Not a recognized archive type: pip

如何为python2.6安装pip?

我对2.6的pip的根需要在this thread中解释。

原网址
A:

只需按照说明here

  1. 安全下载get-pip.py(这是2.6特定的文件,链接来自Ricardo Iramar的答案)。
  2. 在你保存的目录get-pip.py中,运行

    sudo python2.6 get-pip.py
    

    你会准备好的。

这将为Python2.6安装pip,并且不会触及您的2.7版本安装。

所有回答

共 3 条

author avatar

在下面找到在Python2.6上安装pip的步骤。X:

$ curl https://bootstrap.pypa.io/2.6/get-pip.py -o get-pip.py
$ python get-pip.py
author avatar

在fedora/centos系统上,只需使用

yum install python-pip

在其他linux系统上,使用类似yum的安装工具

在window上,使用此问题下的其他解决方案

author avatar

来自本页:pip

pip适用于CPython版本2.6, 2.7, 3.1, 3.2, 3.3, 3.4 而且还 皮皮。

sudo apt-get install python-pip

相似问题