热门标签:
Q:

如何通过easy-install安装特定版本的pip? -Mac OS小牛

我不断地得到

Cannot fetch index base URL https://pypi.python.org/simple/

每当我尝试使用最新的pip版本pip安装任何东西。

我读了一些其他问题,pip在其最新版本中遇到了SSL相关问题,并建议安装pip1.2.1。

例如,如何通过easy_install安装特定版本的pip?

原网址
A:

您应该能够使用pip安装pip:

pip install --upgrade pip==1.2.1

所有回答

共 2 条

author avatar

根据您的上下文,您可以像上面那样卸载,然后运行:

sudo easy_install pip==1.2.1

没有更多讨厌的SSL错误。

author avatar

卸载任何以前安装的pip。 考虑到您正在使用系统范围的安装,

sudo apt-get remove python-pip

而且还,

pip uninstall pip

现在,

sudo apt-get install python-setuptools
sudo easy_install pip==<specific version>
sudo pip install virtualenv

最好使用virtual environment

相似问题