热门标签:
Q:

Ols导入在Pandas中损坏;easy_install找到正确的包,但由于某种原因失败

这可能是来自pandas ols import broken的后续问题?

我在Python2.7上,并且有完全相同的问题,但在解决方面没有与Peter相同的成功。

主要问题是statsmodels的稳定版本是0.6.1。 (每http://statsmodels.sourceforge.net/)。Pandas使用来自statsmodels的OLS函数。api仅在开发版本0.7.0中可用。 我发现很难相信,后2(或更多,如果我的一些搜索结果是相信!)年Pandas还断?

@TomAugspurger建议!pip install statsmodels(我在ipython中这样做)。 有了这个,我得到:

已经满足的需求(使用--升级到升级):c:\users\swang\appdata\local\enthought\canopy\user\lib\site-packages

清理。..

所以!pip install --upgrade statsmodels然后得到我

无法获取索引基URLhttps://pypi.python.org/simple/不能 查找满足statsmodels需求的任何下载 c:\users\swang\appdata\local\enthought\canopy\user\lib\site-packages 下载/解压缩statsmodels清理。.. 没有在 所有在 c:\users\swang\appdata\local\enthought\canopy\user\lib\site-packages 存储故障调试日志C:\Users\swang\pip\pip...日志

尽管statsmodels在中清晰可见https://pypi.python.org/simple/.

!easy_install -U statsmodels给出了最有希望的结果:

搜索statsmodels阅读 http://pypi.python.org/simple/statsmodels/阅读 http://pypi.python.org/simple/statsmodels/无法检索索引 所有软件包的"statsmodels"扫描索引页面(这可能需要一个 阅读http://pypi.python.org/simple/最佳匹配:statsmodels 0.7.0添加statsmodels0.7.0到易于安装。pth文件

使用 c:\users\swang\appdata\local\enthought\canopy\user\lib\site-packages Statsmodel已完成处理的处理依赖项 statsmodels的依赖项下载错误 http://pypi.python.org/simple/statsmodels/:[Errno1]_ssl。c:507: 错误:140770FC:SSL例程:SSL23_GET_SERVER_HELLO:未知协议 -- 有些包裹可能找不到! 下载错误 http://pypi.python.org/simple/statsmodels/:[Errno1]_ssl。c:507: 错误:140770FC:SSL例程:SSL23_GET_SERVER_HELLO:未知协议 -- 有些包裹可能找不到! 下载错误 http://pypi.python.org/simple/:[Errno1]_ssl。c:507: 错误:140770FC:SSL例程:SSL23_GET_SERVER_HELLO:未知协议 -- 有些包裹可能找不到!

是的!!! 0.7.0! 给我! 为什么服务器不打招呼?

我也尝试过!easy_install -U scikits.statsmodels和许多其他变体,但没有成功。

Bottomline/TL;DR-我需要将我的statsmodels升级到0.7.0和pip install --upgradeeasy_install -U不会让我。 我认为easy_install-U让我最接近目标,但在那里失败,我无法弄清楚为什么。 我不认为我在技术上能够从编译原始代码https://github.com/statsmodels/statsmodels/.能否请您建议新手解决这个简单问题的最佳方法?

原网址
A:

0.7.0没有可用的版本;这就是为什么你不能从pip安装它。

您可以访问模块的PyPi页面,了解所有发布的版本

要解决问题,您可以安装开发主干。 值得庆幸的是,该组发布了windows二进制文件,您可以找到一个与您的Python版本兼容的二进制文件。

相似问题