热门标签:
Q:

安装python enviroment python=3.5.2

编辑2021:不要使用PYTHON3.5.2(版本不再支持)

我试图用python=3.5.2创建conda python环境并获得波纹管错误。

  1. 如何添加自定义链接进行安装? 例如https://anaconda.org/anaconda/python/3.5.2/download/win-64/python-3.5.2-0.tar.bz2

conda create -n eapp_env python=3.5.2

收集包元数据(current_repodata.json):完成解决 环境:失败与current_repodata。json,将重试next repodata源。 收集包元数据(repodata。json):完成 解决环境:失败

PackagesNotFoundError:以下软件包不可从 当前频道:

  • python=3.5.2

当前频道:

搜索可能提供conda包的备用通道 你在找,导航到

https://anaconda.org

并使用页面顶部的搜索栏。

原网址
A:

看起来只有3.5.4,3.5.5和3.5.6在anaconda频道的main/win-64索引上可用。 我不确定为什么他们删除了以前版本的3.5。

您可以将频道切换到conda-forge,它仍然具有所有可用的版本。

conda create -n eapp_env python=3.5.2 --channel conda-forge

正如FYI通常一样,包的子子版本仅具有次要更新,不会影响环境中的其他任何内容。

相似问题